Aion Desktop Wallet

This release contains the significantly updated feature set for the Aion Wallet. It features major changes to how keystore files are managed, and a bump in functionality with respect to transaction sending and history.

Features

  • Ability to generate an HD wallet path specific to Aion (m/44’/425’/0’/0’)
  • Ability to create, manage and export accounts from HD path
  • Ability to import and export keystore accounts
  • Ability to send and receive Transactions (limited to currency transfers for now)
  • Ability to view transaction history
  • Ability to view the sync status of the node

Requirements
The wallet is coupled to releases of the Aion kernel, we strongly recommend that this wallet be used with a local node running v0.2.8. Please only submit bug reports if you’re running the wallet with this configuration.

  • Ubuntu 16.04
  • Aion v0.2.8

Links
Aion Desktop Wallet Repo
Wallet Documentation
Blog Post

7 Likes

i try to connect wallet with testnet.I met this error

Prism-ES2 Error : GL_VERSION (major.minor) = 1.4
18-07-06 14:27:00.771 ERROR BSE [pool-4-thread-1]: [connect] Connect failed.
18-07-06 14:27:06.779 ERROR BSE [pool-4-thread-1]: [connect] Connect failed.
18-07-06 14:27:10.880 WARN BSE [pool-3-thread-1]: API not initialized yet!
18-07-06 14:27:10.884 WARN BSE [pool-3-thread-1]: API not initialized yet!
18-07-06 14:27:10.887 WARN BSE [pool-3-thread-1]: API not initialized yet!
18-07-06 14:27:10.908 ERROR WLT [pool-3-thread-1]: Could not get SyncInfo - sync displays latest block!
18-07-06 14:27:10.908 WARN BSE [pool-3-thread-1]: API not initialized yet!
18-07-06 14:27:10.939 ERROR WLT [api]: null
java.lang.NullPointerException: null
at org.aion.wallet.connector.api.ApiBlockchainConnector.getSyncInfo(Unknown Source)
at org.aion.wallet.ui.components.partials.SyncStatusController.lambda$refreshView$0(Unknown Source)
at org.aion.wallet.ui.components.AbstractController$1.call(Unknown Source)
at javafx.graphics/javafx.concurrent.Task$TaskCallable.call(Unknown Source)
at java.base/java.util.concurrent.FutureTask.run(Unknown Source)
at java.base/java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
at java.base/java.util.concurrent.FutureTask.run(Unknown Source)
at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at java.base/java.lang.Thread.run(Unknown Source)
like this.

Has anyone tried running the wallet with old kernel.

Hi @lura ,

That happens because it can’t connect to the node. Can you check the node’s config? It has to have the java api enabled on that interface.

By default the node only accepts java api connections on localhost (127.0.0.1)
If you are not connecting to a local node, then you have to update the node’s config to be able to connect on a different interface. To connect on all interfaces, you have to update the node’s config to something like:

<aion>
    ...
    <api>
        ...
        <java active="true" ip="0.0.0.0" port="8547"></java>
        ...
    </api>
    ...
</aion>

hi @sk22 ,

Most of the features should work, but the kernels before 0.2.8 had some Java API issues so it might cause some unexpected behavior here and there.

HD wallet creation and recovery, as well as, importing and exporting can be done offline (no node connection is required)

Thanks… I have my miner on old kernel version… don’t want to break things :slight_smile: I guess now it’s time to update…

Indeed, the latest kernel has a bunch of improvements and fixes, be sure to backup your keystore if you haven’t already.

1 Like

Hi guys. I’ve updated the kernel to 0.2.8, i’ve installed the wallet, and I have the following issue on one of my accounts: Dashboard balance different than Wallet balance (see in picture). I’m mining with a small rig, like 1 AION / day on Luxor, so the Wallet app is like almost 3 weeks behind… :slight_smile:
image

… also, on a wallet restart, I have this on my Terminal window (the graphical app started ok, aion.sh is runing ok):

1 Like

If your kernel has not fully synced you won’t be seeing your current balance. The wallet is essentially just a graphical interface to the kernel.

1 Like

Thanks, got that, I’ll wait some more. Other account it’s showing ok number…

Now, after 7 hours, it caught up, so it is ok, thanks!

Different question for you, guys. How / where do you backup / export account keys on the cloud? How do you “keep it safe”, even from computer disaster? ( If the question is inappropriate on raise security concerns, forgive me!)

I am a Windows guy who still struggle a little bit with Linux, and now, with this working Desktop Wallet, I was not able to Import an account using the key file, with only Copy / Paste method (account created awhile ago with earlier version of aion.sh on the same Ubuntu machine, by the root account - I did not know any better at that time :slight_smile: - ) … It keep asking me to complete the required fields, even if the file and password were the right ones.

I’m storing my private keys / keystore files in the following way:

Bit of a hassle to set up, but once you do you are pretty much safe, unless your system is compromised (i.e. has a keylogger or some other spyware on it). Then I store my volume with the keys on it in the cloud and on several usb sticks, it doesn’t really matter. Just remember your password :wink:

2 Likes

when i run this command ./aion_wallet.sh i got the following below error
Before that i follow the steps what ever provided in the linkhttp://docs.aion.network/Account%20Management/.

So please any one help me

aion_wallet/aion_wallet-v1.0.0.e446419e-2018-07-05$ ls
aion_wallet.sh jre lib mod native
aion_wallet/aion_wallet-v1.0.0.e446419e-2018-07-05$ ./aion_wallet.sh
./aion_wallet.sh: line 11: jre/bin/java: No such file or directory

This looks like java is not installed correctly on your system, I’d question whether you also actually have the Aion Kernel running as the first step too then?

I installed java 10 and i created aion testnet also but it again shows the same error

What Linux release are you running?

am using currently linux 16.04 lts

Assuming you’re wanting to build from source rather than run a release?

Check your environment settings are correct, including the Ant execute path, java execute PATH link to the JDK10 folder, and the JAVA_HOME before building.

https://github.com/aionnetwork/aion/wiki/Build-your-Aion-network

ok sure i ill check it again