personal.listAccounts fails - cannot read property

I’ve got the latest kernel version 3.2 up and running without issue. I let it sync from scratch.

Now I’m trying to install and run the console. It seems to install correctly, and the console launches, but when I try to run the command personal.listAccounts I get an error instead of a printout of the public keys that I have in the keystore directory.> personal.listAccounts
TypeError: Cannot read property ‘listAccounts’ of undefined

What am I missing here? This has worked for me in the past. I believe I have everything installed correctly. I am following the steps in the AION owner’s manual.

aion_web3$ nodejs --version
aion_web3$ npm --version

I upgraded npm but the issue still repros =(

aion_web3$ npm -v
aion_web3$ node -v

personal.getAccounts () will return you an array of accounts on your node.

The problem is that it’s not working for him, although I don’t know why, because it is working for me on the latest kernel version.

@xalspaero can you make other web3 calls ? such as getBalance ()

No. I think getBalance only works after you unlockAccount right? I get the same error when trying to unlockAccount.

this is a transaction I took from the explorer -

can you try web3.eth.getTransactionReceipt (‘a1078699666188e4f43d7ced5a4e0650d0a637d18eedcb62cc98e591006332ed’)

sorry it’s been a while but I’m coming back to this thread again. I just installed the latest kernel 3.2.1 and synced it. fresh install of aion_web3 and I still have the same issue! blah. I tried your command, here is what I see:> web3.eth.getTransactionReceipt(‘a1078699666188e4f43d7ced5a4e0650d0a637d18eedcb62cc98e591006332ed’)
Promise {
Domain {
domain: null,
[Object: null prototype] {
removeListener: [Function: updateExceptionCapture],
newListener: [Function: updateExceptionCapture],
error: [Function: debugDomainError] },
_eventsCount: 3,
_maxListeners: undefined,
members: [] } }> (node:5860) UnhandledPromiseRejectionWarning: Error: Invalid JSON RPC response: “”
at Object.InvalidResponse (/home/raptorwrangler/Downloads/aion321/aion_web3/packages/web3-core-helpers/src/errors.js:46:16)
at XMLHttpRequest.request.onreadystatechange (/home/raptorwrangler/Downloads/aion321/aion_web3/packages/web3-providers-http/src/index.js:89:32)
at XMLHttpRequestEventTarget.dispatchEvent (/home/raptorwrangler/Downloads/aion321/aion_web3/packages/web3-providers-http/node_modules/xhr2-cookies/dist/xml-http-request-event-target.js:34:22)
at XMLHttpRequest._setReadyState (/home/raptorwrangler/Downloads/aion321/aion_web3/packages/web3-providers-http/node_modules/xhr2-cookies/dist/xml-http-request.js:208:14)
at XMLHttpRequest._onHttpRequestError (/home/raptorwrangler/Downloads/aion321/aion_web3/packages/web3-providers-http/node_modules/xhr2-cookies/dist/xml-http-request.js:349:14)
at ClientRequest. (/home/raptorwrangler/Downloads/aion321/aion_web3/packages/web3-providers-http/node_modules/xhr2-cookies/dist/xml-http-request.js:252:61)
at ClientRequest.emit (events.js:182:13)
at ClientRequest.EventEmitter.emit (domain.js:441:20)
at Socket.socketErrorListener (_http_client.js:392:9)
at Socket.emit (events.js:182:13)
(node:5860) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). (rejection id: 2)

btw, one thing I haven’t tried is reinstalling ubuntu and installing everything all over again from scratch, but I’d like to avoid that if possible and also learn how to troubleshoot this issue in the future.

if I run node console.js in the aion_web3 dir, without having launched the aion kernel first, it still seems to bring up the prompt, as though it doesn’t even care that the kernel is not running. shouldn’t it fail instead?

Connected to default> (node:5985) [DEP0005] DeprecationWarning: Buffer() is deprecated due to security and usability issues. Please use th e Buffer.alloc(), Buffer.allocUnsafe(), or Buffer.from() methods instead.

I started all over from scratch, inside a VM. same repro! here is the full list of all my steps so you can see what I’m doing. what am I missing exactly???

  1. created a VM in virtual box with these specs:
    • memory: 8 GB
    • storage: 1024 GB
    • ubuntu 18.04.2 LTS
  2. install ubuntu updates
  3. install guest additions to enable drag & drop to copy in my keystore files easily

new terminal window, cd to Downloads…

  1. wget
  2. extract
  3. run ./ to run kernel and let the node fully sync (takes several hours)

new terminal window, cd to Downloads…

  1. check node version (not installed by default)

  2. check nvm version (not installed by default)

  3. check npm version (not installed by default)

  4. sudo apt-get install curl

  5. curl -o- | bash

  6. nvm install 10.15.1

  7. node -v (verified 10.15.1)

  8. npm -v (verified 6.4.1)

  9. sudo apt-get install git

  10. git clone

  11. cd aion_web3

  12. npm install

    aion-web3@1.0.0 postinstall /home/vdrew/Downloads/aion_web3
    lerna bootstrap

    lerna info version 2.11.0
    lerna info Bootstrapping 18 packages
    lerna info lifecycle preinstall
    lerna info Installing external dependencies
    lerna info Symlinking packages and binaries
    lerna info lifecycle postinstall
    lerna info lifecycle prepublish
    lerna info lifecycle prepare
    lerna success Bootstrapped 18 packages
    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.4 (node_modules/fsevents):
    npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.4: wanted {“os”:“darwin”,“arch”:“any”} (current: {“os”:“linux”,“arch”:“x64”})

    added 1023 packages from 999 contributors and audited 6317 packages in 83.97s
    found 166 vulnerabilities (160 moderate, 6 high)
    run npm audit fix to fix them, or npm audit for details

  13. copy keystore files into aion mainnet keystore dir

  14. restart kernel in the other terminal window

  15. node console.js

  16. personal.listAccounts

TypeError: Cannot read property ‘listAccounts’ of undefined

That’s a super weird bug man.